CS-Lab Support Forum for CNC Community

Help to run this brand-new forum and stay with us.
Ask your questions, we are here to help! 


Forum breadcrumbs - You are here:ForumWelcome: CNC support Forumcrash
Please or Register to create posts and topics.


Page 1 of 2Next

Good morning,during machining there was an incident and the machine stopped. I have a csmio-ip/s controller running reconnecting to the drive I now know that it had lost (all?) settings as when I pressed ref all it punched the 1/8 bit through the material. I then turned the power off and reloaded simcnc when i moved the x axis it didnt move the slave a at the same time.

Having had a similar thing a couple of months ago wher the profile had disappeared I changed profile to a copy from earlier in the day and all worked as expected.

In the email that I sent last night gmail and then your mail server wouldnt allow me to send the zips of the folders with files so I'm trying here


as ever chris


There is no link to the configuration profile in this message.
I need:
* information which version of simCNC you use
* configuration profiles: the correct one and the one that was damaged, to be able to analyze what happened there



Hi andrew,

the version is 3.5 

There seems to be a problem with profiles here are screen shots, the one left is the ok one and the one on the right is the folder with the crash profile, except I cant find any profiles just a shortcut to the profiles folder which is recursive. 

I am looking in c:\program files\simcnc\profiles\cem1 is this the correct location


as ever chris

Uploaded files:
  • screen-8-aug.png

I think you've made a mistake.
I think the one on the left looks damaged because there is no config.xml file in it.
If simCNC does not find the config.xml file in the profile folder, it starts with basic settings that match your failure's description.

The folder "profiles - shortcut" and "archive scripts.zip" were probably created by you yourself because simCNC does not do such a thing.

One more minor clarification, the profile in your case is the "CEM1" folder.
I wanted to explain it to you because I got the impression you didn't know it.

I talked to our developer, and he has to do a series of tests to check whether there is a risk of losing the config.xml file when the network connection is lost.
The point is that when the connection is lost, an emergency save of the current simCNC settings is made to the config.xml file.
Based on your report, we have become concerned that the failover algorithm that is part of the Qt standard library may have a weakness.


thanks for the reply, I was unable to post the profile before as it is not a file , hence the zip which meither gmail nor your server would allow.

I have had another crash and am now working through network connections. When I reload simcnc following the crash I find theat cem1 is showing as loaded but when looking in settings it is blank, in file explorer config.xml is showing as the time of the crash. Last night the machine stopped in the middle of ref all with an odd noise, as i investigated all steppers wher making a vibrating noise and the controller had 2 status lights flashing. I turned it off and found loose bolts on the gantry rail slides which I've replaced, I cant see how that caused the crash during y movement. Today ref all worked as expected.

Now I have 1 status light flashing and the network lights flashing however the controller doesnt show in simcnc. This happened yesterday and required a reboot to be seen. Im going to post and reboot now




I've restarted the pc and the controller is now seen . The configuration is still shown as cem1 but the setting s creen is now sloghtly different i enclose the first screen of motion kits. My concern is that the limit switches are not showing. Do you know what is happening here?

Im going to try a different pc now


Uploaded files:
  • Screenshot-2023-08-18-131815.png

So this crash which seems to be network related has happened a further 4 times over the weekend. Each time it seems to remove the contents of the config file which is dangerous because if you dont know its happened and you press ref all then the z goes down instead of up. I have now worked out how to save a good copy of the config.xml file and restore whilst I try to find the issue. Could it be my controller?

I have swapped back to the original laptop which is running 3.50 (the new laptop running 3.501) this required a firmware change which I did it hung at 0.3 then 53 then 97 then 86 and finally reloade each time I had to turn off then connect the 3.501 laptop which again tried and stalled in the update process but that then allowed the 3.50 machine to restart the firmware update.

Do you have any ideas?


I understand that you are on holiday



Uploaded files:
  • Screenshot-2023-08-21-153008.png

again 200 lines of code in and a crash

should I reinstall? My concern with that is that there are 2 places that scripts can be saved and it seems arbitrary where they are. The question is how to ensure none are overwritten where theyve been changed from the vanilla ones

Uploaded files:
  • Screenshot-2023-08-21-160120.png
  • Screenshot-2023-08-21-160241.png
  • settings-after-crash-before-restart.png
  • settings-after-crash-following-restart.png

Please do not make any changes within simCNC. Together with our software developers, we prepare a solution for you that will require your participation and your machine in its current state.



After a thorough review of your application, our software developer discovered that there is a small chance that some simCNC configuration will be lost due to connection loss.
This issue will be fixed in 3.501 Beta 2.

Regarding frequent loss of network connection, you need to read the guide in the link below thoroughly.
This step-by-step guide eliminates possible causes.

Page 1 of 2Next





Slovenia / Bosnia


South Africa


The Netherlands



  Distrib milionis logo


Distrib logot




Proteq Automation




Jun Ma




LVL tech r


Varntoft Dania




Click one of our contacts below to chat on WhatsApp

× How can I help you?